Joget not running

Confluence User - 15 Apr, 2021

Tomcat is working but joget not working

when I start the joget the localhost:8080 is working but localhost:8080/jw is not working and redirect to localhost:8080/jw/setup

I tried to stop joget and start many times but it doesnt worked

this is the log when I start joget:

log.txt

start;setup;jogetdx

2


16 Apr, 2021
confluenceUser
confluenceUser

Sounds like the database is not up and running or some other issues relating to the DB, see Troubleshooting - Common Errors for more information. You can check the joget.log file in "[JogetRool]\apache-tomcat-8.5.58\logs" for the error logs.

24 Feb, 2023
confluenceUser
confluenceUser

According to the log file you provided, it appears like Joget is running into a database connection problem. Joget is unable to connect to the database using the given JDBC driver and connection URL, according to the error message "Cannot construct JDBC driver of class " for connect URL 'null'".

To troubleshoot this issue, you can try the following steps:

  1. Check that the database server is running and accessible from the machine where Joget is installed. You can try connecting to the database using a database client tool, such as MySQL Workbench, and see if you are able to connect successfully.

  2. Check that the database configuration in the Joget setup wizard is correct. Specifically, make sure that you have specified the correct database driver and connection URL, as well as the correct database username and password.

  3. Check that the JDBC driver for your database is included in the Tomcat lib directory. You may need to download and manually install the driver if it is not included by default.

  4. Check the Joget configuration files (such as joget.override.properties and server.xml) to see if there are any incorrect or missing settings related to the database configuration.

If none of these steps resolve the issue, you may need to consult the Joget documentation. 

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print