Joget DX8 Install on Kubernetes fails to detect configuration

Confluence User - 20 Jun, 2023

We installed DX8 using the getting started guide. When we start the web ap, we get the /setup prompt. We entered the MySQL connection string and successfully created the jwdb in an external MySQL instance. However, any further attempts to connect redirect us back to the /setup page. Trying to recreate the DB fails because it already exists. Creating with another name creates the DB again with another name, but Joget fails to detect that configuration either.

jogetdx

2


20 Jun, 2023
confluenceUser
confluenceUser

Hi, which container image are you using, and did you follow the steps from Joget on Kubernetes? Try checking for the error messages in the pod logs, they should give a clearer idea on what the actual problem could be.

27 Jun, 2023
confluenceUser
confluenceUser

Yes, we followed  Joget on Kubernetes

Pasted a sanitized log into the comment above. 

Saving the profile fails with permission denied.

It looks like the installer doesn't properly set permissions when we don't use the "default" namespace.

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print