Getting Error code 403 on Windows Installation

Confluence User - 21 Jul, 2021

Hi there,

I have perform a windows enterprise version on installation and it prompt error 403 after i launch the app center.


Any advise on this matters?


Thank you

Regards

Andrew

installation;windows;enterprise

5


22 Jul, 2021
confluenceUser
confluenceUser

Do use this guide Troubleshooting - Common Errors to troubleshoot your issue. The joget log files are in "[JogetRootFolder]\apache-tomcat-8.5.65\logs".

22 Jul, 2021
confluenceUser
confluenceUser

Thanks Matthew,


Here is the log and it seems Error on initializing WebApplicationContext.


INFO 22 Jul 2021 16:23:22 org.joget.commons.util.SetupManager - Using base directory: ./wflow/
INFO 22 Jul 2021 16:23:25 org.joget.commons.util.DynamicDataSource - profileName=default, url=jdbc:mysql://localhost:3307/jwdb?characterEncoding=UTF-8&useSSL=false&allowPublicKeyRetrieval=true, user=root
ERROR 22 Jul 2021 16:23:26 org.joget.commons.spring.web.CustomContextLoaderListener - ===== Error initializing WebApplicationContext =====
INFO 22 Jul 2021 16:23:26 org.displaytag.filter.ResponseOverrideFilter - Filter initialized. Response buffering is enabled


This is a new installation and nothing have been configure yet

22 Jul, 2021
confluenceUser
confluenceUser

The "Error initializing WebApplicationContext" error means that Joget could not connect to your database as defined in the ".\wflow\app_datasource-default.properties". It could also be caused by insufficient database user permission. With the correct database user permissions, Joget will have the full privileges to automatically create the system tables it needs to run Joget. Read Custom Database Configuration 

22 Jul, 2021
confluenceUser
confluenceUser

Thanks Matthew.

As i mention, this is a new installation and nothing have been configure include the database. According to the user installation guide, after download the installation file and install the application. MariaDB should be installed together as well. Nothing have been prompt to me during the installation stage.

Do you able to advise what step i have miss or i need to change the configuration of the DB connection?

22 Jul, 2021
confluenceUser
confluenceUser

You need to look into the log file for the answer. Then compare the error to the list in Troubleshooting - Common Errors. Or delete the Joget folder and try reinstalling everything again. Ensure no other Apache Tomcat is running on port 8080. Cheers.

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print