Admin Role with LDAP
HI,
I am currently trialling Joget Enterprise and am trying to setup LDAP Directory Manager with Active Directory against the root domain of our forest. As a proof of concept I am trying to permit users from multiple child domains to login so have tried using for example DC=contoso,DC=com for most DNs (I have narrowed it down to specific OUs during troubleshooting) and utilised extensionAttribute7 to specify whether a user is licensed or not (0 or 1).
Through this I have users logging in (though some supposedly licensed users are refused for not having a license despite authenticating successfully) and the credentials used for LDAP admin are refused login with incorrect username\password (I have read on some other posts that one of the other LDAP manager plugins permits both a local and LDAP user model so I may try this at some point).
My biggest issue though is that I do not seem to be able to find the correct configuration for the Admin Role page in order to elevate some of my LDAP users to an Admin Role. So far I have tried the following:
- Specify an OU containing the desired Admin user(s)
- Adding a search filter to the above to select a single user
- Specify an OU containing only a Security Group whose members are the desired admin(s) with the Attribute Mapping - Users and Map to LDAP User Entry Primary Attribute specified
- Added a search filter to the above to select the sole Security Group in the OU
- Added different users into the above Security Group (normal users and\or the LDAP Admin user for instance)
Unfortunately they do not appear to have an impact and the users remain with the standard role or in the case of the LDAP admin user, are still unable to login. The debug log reports successful authentication for all LDAP users (except the LDAP Admin user) and reports that LDAP users are otherwise checked to see if they are an admin but not whether or not this is determined to be true. These are interspersed with a large number of the default 'admin not found in LDAP' errors related to me making changes under the default user whilst testing.
Any help would be appreciated.
Thanks.