Installation on Weblogic 12c (12.1.3.0.0)

Confluence User - 25 Oct, 2016

Installation quotes:

Installation on Weblogic 12c (12.1.3.0.0)

  1. Deploy the jw.war and jwdesigner.war files, they should work as normal.

 

However, during the jw deployment the startup fails with:

<Oct 24, 2016 9:25:01 AM PDT> <Warning> <Deployer> <BEA-149004> <Failures were detected while initiating deploy task for application "jw".>
<Oct 24, 2016 9:25:01 AM PDT> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
weblogic.application.ModuleException: java.lang.NoClassDefFoundError: Could not initialize class org.apache.xerces.impl.xs.XMLSchemaValidator

 

looking in the weblogic jar files, there are multiple instances of xercesImpl already @ older version levels.

 

[oracle@soa-training ~]$ find /u01/fmw/joget/ -name "*xerces*"
/u01/fmw/joget/oracle_common/modules/oracle.owasp_12.1.3/com-bea-core-apache-xercesImpl.jar
/u01/fmw/joget/wlserver/plugins/maven/com/oracle/weblogic/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1
/u01/fmw/joget/wlserver/plugins/maven/com/oracle/weblogic/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1/12.1.3/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1.12.1.3.pom
/u01/fmw/joget/wlserver/plugins/maven/com/oracle/weblogic/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1/12.1.3/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1.12.1.3.location
/u01/fmw/joget/wlserver/modules/com.bea.core.apache.xercesImpl_1.0.0.0_2-8-1.jar
/u01/fmw/joget/wlserver/modules/com.bea.core.apache.xerces.resolver_1.0.0.0_2-8-1.jar
/u01/fmw/joget/wlserver/modules/com.bea.core.apache.xerces.xml-apis_1.0.0.0_2-8-1.jar

 

I suspect this is a "class loader conflict." similarly documented in the "Installation on Glassfish 4.1".

the latest xercesImpl is in the WEB-INF/lib folder of jw.war, but upon startup weblogic is not using the "local" xerces jar first. 

What is the resolution for this problem, can I get the weblogic server to reference the jar files in the deployment lib during runtime first? Also please update the installation instructions on the "Installation on Weblogic 12c (12.1.3.0.0)" for other persons.

 

This is an oracle OTN SOA 12.1.3 Linux Developer vm. I tried with both the original VM, and then I re-installed with ONLY weblogic (thinking the conflict might be the result of having SOA & oracle BPM installed already).. But it looks like this is a core Weblogic conflict. 

 

installation

3


25 Oct, 2016
confluenceUser
confluenceUser

Hi, did you try using the Enterprise Edition? I am not sure if the Community Edition supports running on Weblogic.

27 Oct, 2016
confluenceUser
1
confluenceUser

Hi, I had downloaded my copy of Weblogic from http://download.oracle.com/otn/nt/middleware/12c/wls/1213/wls1213_dev.zip and when I deploy the enterprise jw.war, it is working and I am not getting your error.

28 Oct, 2016
confluenceUser
confluenceUser

Yep, looks like that works. If ONLY weblogic is installed on the domain. I was installing to an enterprise deployment of weblogic "Oracle Fusion Middleware Infrastructure" so the domain could be used for other SOA deployments in an enterprise fashion. For right now, that's not a requirement. Thanks for the effort. Perhaps you should mention that Joget should only be deployed on a standalone weblogic server and it has not been tested on more complex weblogic environments such Oracle Fusion middleware. Again, Thanks.

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print