failed to read schema during deploy

Confluence User - 26 Nov, 2020

I am trying to deploy a simple process (roughly based on the tutorial video) and it fails with tie following errors:

Deployment Error: Type=ERROR, Sub-Type=SCHEMA, Location=Package 'test' 
[Warning] at line number 2 schema_reference.4 Failed to read schema document 'http//wfmc.org/standards/docs/TC-1025_schema_10_xpdl.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsdschema>.


Type=ERROR, Sub-Type=SCHEMA, Location=Package 'test'
[Error] at line number 2 cvc-elt.1.a Cannot find the declaration of element 'Package'.


Type=ERROR, Sub-Type=SCHEMA, Location=Package 'test'
[Warning] at line number 3 schema_reference.4 Failed to read schema document 'http//wfmc.org/standards/docs/TC-1025_schema_10_xpdl.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsdschema>.

Then many repeats of the last few lines.

I note in the messages there is no ":"  between the "http" and "//".  Is that significant?

Using joget linux 7.0.11 downloaded a couple of days ago on Centos 8

Any ideas?



deploy;setup

4


27 Nov, 2020
confluenceUser
confluenceUser

Hi, that is indeed strange. What edition of Joget are you running and how did you install it? Perhaps you can try on a different installation or try using an account on cloud.joget.com.

01 Dec, 2020
confluenceUser
confluenceUser

I am using the community edition  joget-linux-7.0.11.tar.gz VERSION.txt says: "7.0.11 - build 235b03a" from http://sourceforge.net/projects/jogetworkflow/files/joget-linux-7.0.11.tar.gz/downloadInstallation:


Looking back at my history I basically did the following for the installation;

  • Untarred the tar file
  • Installed mysql
  • Created jwdb database
  • Installed Ant
  • Ran joget-linux-7.0.11/setup.sh
  • cd joget-linux-7.0.11/
  • Ran apache-ant-1.7.1/bin/ant setup
  • Ran ./tomcat8.sh run


02 Dec, 2020
confluenceUser
confluenceUser

Tried again with new database and install. Went straight to ./tomcat.sh start and filled in database details on the web interface. Entered a trivial process and tried to deploy. Got the same errors.

02 Dec, 2020
confluenceUser
confluenceUser

I just tried the jogetworkflow/joget-enterprise docker container. That has different issues (various error pages if you try and create a process or if you try and use one of the preinstalled examples).  I have exhausted the time I can spend on this.

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print