IIS Reverse Proxy For Joget (Tomcat)

Confluence User - 16 May, 2019

hi, i'm setting up iis reverse proxy with ssl point to tomcat(localhost:8080). the problem is it cant rewrite back with domain defined in iis and errors related with CsrfGuard referer domain. (windows 2012 server)

server;reverseproxy

2


16 May, 2019
confluenceUser
confluenceUser

Perhaps you can take a look on this link https://blogs.msdn.microsoft.com/friis/2016/08/25/setup-iis-with-url-rewrite-as-a-reverse-proxy-for-real-world-apps/

The issue most likely is caused by the mismatch of host header.

17 May, 2019
confluenceUser
confluenceUser

I’ve had this issue before with another reverse proxy. (NGINX)

These are my notes from back then which may apply in a similar way to IIS

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print