Error Starting Joget after upgrade java

Confluence User - 25 Aug, 2019

Halo expert,

After upgrading java and resulting this :

java version "12.0.2" 2019-07-16
Java(TM) SE Runtime Environment (build 12.0.2+10)
Java HotSpot(TM) 64-Bit Server VM (build 12.0.2+10, mixed mode, sharing)

Starting joget is very hard, log captured :


WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.aspectj.weaver.loadtime.ClassLoaderWeavingAdaptor (file:/opt/jw/wflow/aspectjweaver-1.8.5.jar) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
WARNING: Please consider reporting this to the maintainers of org.aspectj.weaver.loadtime.ClassLoaderWeavingAdaptor
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release


Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.



25-Aug-2019 01:21:28.762 INFO [main] org.apache.coyote.AbstractProtocol.pause Pausing ProtocolHandler ["http-nio-8080"]
25-Aug-2019 01:21:28.815 INFO [main] org.apache.catalina.core.StandardService.stopInternal Stopping service [Catalina]
INFO 25 Aug 2019 01:21:42 org.joget.apps.app.web.ThreadCleaner - cleaned 360 values in ThreadLocals
log4j:WARN No appenders could be found for logger (bitronix.tm.BitronixTransactionManager).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
25-Aug-2019 01:21:42.673 WARNING [localhost-startStop-1] org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesJdbc The web application [jw] registered the JDBC driver [org.mariadb.jdbc.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
25-Aug-2019 01:21:42.674 WARNING [localhost-startStop-1] org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesJdbc The web application [jw] registered the JDBC driver [org.mariadb.jdbc.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
25-Aug-2019 01:21:42.690 INFO [main] org.apache.coyote.AbstractProtocol.stop Stopping ProtocolHandler ["http-nio-8080"]
25-Aug-2019 01:21:42.692 INFO [main] org.apache.coyote.AbstractProtocol.destroy Destroying ProtocolHandler ["http-nio-8080"]


My tomcat8.sh is here :

#!/bin/sh

export JAVA_OPTS="-XX:MaxPermSize=256m -Xmx1024M -Dwflow.home=./wflow/ -XX:+Use$

apache-tomcat-8.5.16/bin/catalina.sh $*


How should i fix this ? Thank you

server

1


26 Aug, 2019
confluenceUser
confluenceUser

Hi, what version of Joget are you running? I believe you will require a newer version for newer versions of Java.

RELATED QUESTIONS

Your answer


To answer a question you'll need an account.

Print